3 users online | 3 Gäste und 0 Registrierte

Ich kann meinen Server nicht aktualisieren, bekomme folgende Meldung:
SSL routines:SSL23_GET_SERVER_HELLO:reason(1112)


Durch ein Update des Update-Servers musste aus Sicherheitsgründen auch OpenSSL auf den neusten Stand gebracht werden. Dadurch sind Kompatibilitätsprobleme beim Update von älteren Collax-Server-Versionen entstanden.

Folgende Ausgabe ist bei Collax Server mit Versionen kleiner 5.5.18 und V-Cube Versionen kleiner 6.1.12 zu sehen, nachdem man auf „Update Pakete holen“ geklickt hat:
(Kurzfassung)

 

0% [1 Packages 0](35) error:14077458:SSL routines:SSL23_GET_SERVER_HELLO:reason(1112)Err custom://update.collax.com csg55/main Packages

Sub-process /usr/lib/apt/custom/pynix

Update returned an error code (35)W: You may want to run apt-get update to correct these problems

E: Some index files failed to download, they have been ignored, or old ones used instead.

 

Um ältere Collax Systeme dennoch aktualisieren zu können, ist ein manueller Eingriff vor dem System Update erforderlich. Wie das genau funktioniert, wird nachfolgend beschrieben:


Die nötigen Pakete sind nun auf dem Update-Server in einem öffentlich erreichbaren Verzeichnis hinterlegt.
Für Cxx 5.5 (32 Bit):
http://update.collax.com/pub/openssl_0.9.8za-ak38a4_i386-for-cxx55.deb
Für Cxx 5.5 (64 Bit):
http://update.collax.com/pub/openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb
Für VCube 6.1:
http://update.collax.com/pub/openssl_0.9.8za-ak38a4_amd64-for-vc61.deb
Um die Pakete  auf den betroffenen Maschinen zu installieren, gehen Sie wie folgt vor:

 

1.    Per SSH als Benutzer Admin einwählen und danach zum Benutzer Root wechseln.
(Beispiel)

 

user@cbs:~$ ssh admin@cgs.example.com
Password:
Last login: Wed Jul 29 17:57:41 2015 from cbs.example.com
Welcome to Collax Groupware Suite version 5.5.12
admin@cgs:~$ su -
Password:
root@cgs:~#

 

2.    Mit dem Befehl "uname -a" können Sie bei C-Produkten herausfinden ob Sie ein 32- oder 64-Bit-System haben. Dementsprechend laden Sie das Paket von unserem Update Server herunter. Beispiel für ein 64-Bit-System:

 

root@cgs:/home/admin# uname -a

Linux m 2.6.32.67 #1 SMP Wed Aug 5 14:03:38 CEST 2015 x86_64 GNU/Linux

root@cgs:/home/admin#

 

3.    Paket wie folgt herunterladen.Das Beispiel zeigt, was auf einem 64-Bit-Server passiert nach dem Sie ENTER gedrückt haben. Die URL muss abhängig dem System angepasst werden.

 

root@cgs:/home/admin# wget http://update.collax.com/pub/openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb

converted 'http://update.collax.com/pub/openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb' (ANSI_X3.4-1968) -> 'http://update.collax.com/pub/openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb' (UTF-8)--2015-09-16 16:31:42--  http://update.collax.com/pub/openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb

Resolving update.collax.com (update.collax.com)... 85.10.236.187

Connecting to update.collax.com (update.collax.com)|85.10.236.187|:80... connected.

HTTP request sent, awaiting response... 200 OK

Length: 1037326 (1013K) [application/x-debian-package]

Saving to: 'openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb'openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb

100%[====================================================================================================>]

1013K  2.91MB/s   in 0.3s

2015-09-16 16:31:43 (2.91 MB/s) - 'openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb' saved [1037326/1037326]

root@cgs:/home/admin#

 

4. Nun installieren Sie das heruntergeladene Paket mit dem Befehl:

 

root@cgs:/home/admin# dpkg -i openssl_0.9.8za-ak38a4_amd64-for-cxx55.deb

 

Nach der Installation die nur wenige Sekunden dauert, können Sie ganz normal mit dem Update des Systems fortfahren.

Letzte Änderung:
2015-11-03 17:39
Verfasser:
Angelito Duricin
Revision:
1.5
Durchschnittliche Bewertung: 5 (4 Abstimmungen)

Kommentieren nicht möglich

Chuck Norris has counted to infinity. Twice.